Příspěvky uživatele


< návrat zpět

Strana:  1 ... « předchozí  3 4 5 6 7 8 9 10 11   další » ... 78

Nekam do kodu (treba nakonec config.php) je treba dat tento radek:
header('Expires: ' . gmdate('D, d M Y H:i:s', time() - 604800));
Nektere hostingy totiz nastavuji vychozi Expires hlavicku a to rozbije prihlasovani. Budouci verze toto opravi.

Omezeni je i v editpost.php a post.php.

Kdyby to byl cílený a úspěšný útok, očekával bych mnohem více spamu. Může se jednat o ojedinělý případ nebo ten kód někdo opsal manuálně.

Soubor admin/functions.php, funkce _admin_rootSelect(), argument $maxlength = 22.

Vola se v souboru admin/require/content-articles-edit.php.

Důvod je to, co jsem popsal. Něco ti tam cpe BOM.

/ke-stazeni/stare-verze

V require/load.php si najdi define('_systemversion', ....

Obrázek to generuje správně, akorát je před daty obrázku UTF-8 BOM, takže nějaký tebou editovaný soubor (pravděpodobně config.php nebo skript nějakého pluginu) bude uložen v kódování UTF-8 s BOM namísto UTF-8 bez BOM.

A jak je velká ta záloha? Nenahráváš ji v textovém režimu (přes FTP)? Pak by došlo k jejímu poškození.

Dle jejich webu se jedná o "drop-in" náhradu za MySQL, čili SL by měl fungovat bez jakýchkoliv změn.

Bylo to způsobeno PHP kódem 3. strany (nějaká knihovna), chyba není v SL ani v žádných systémových rozšířeních.

Nebo zavirovaný počítač. Poslední známá bezp. chyba byla v SL <= 5.3.

"Starší verze Sunlight" je dost obecný pojem. Tipuju starší než 7.0.0.

DB::insertID()

Co znamená "vyhodí chybu" netuším. Měl bys prostě vrátit jedno pole pro insert jednoho řádku. Pokud potřebuješ vkládat další řádky, které závisí na tom, který právě vytváříš, tak si je budeš muset vložit všechny ručně.

BTW MyISAM tabulky nepodporují transakce.


Strana:  1 ... « předchozí  3 4 5 6 7 8 9 10 11   další » ... 78